Increased 502 responses to our Core API
Incident Report for Flagsmith
Resolved
This incident has been resolved.
Posted Jun 27, 2022 - 07:21 UTC
Monitoring
The errors have been resolved. We are continuing to monitor this.
Posted Jun 26, 2022 - 17:51 UTC
Investigating
We are still seeing elevated 502 errors and are continuing to investigate. These issues are isolated to our Core API only and seem to be affecting ~0.1% of Core API requests only. Our Edge API continues to be fully operational.
Posted Jun 24, 2022 - 20:26 UTC
Monitoring
We have deployed a fix and are monitoring our container memory consumption.
Posted Jun 24, 2022 - 14:18 UTC
Investigating
Hi,

We are experienced slightly elevated 502 errors returning from our Core API. We believe this is due to a recently introduced piece of code that is consuming more memory than it should be and are working on a fix.
Posted Jun 24, 2022 - 13:54 UTC
This incident affected: API (Core API) and Admin Dashboard.