The issue was caused by a spike of unusual traffic. This traffic has been mitigated and the issue is resolved.
Posted Jul 23, 2025 - 21:17 UTC
Investigating
We're seeing a delay in processing tasks by our asynchronous task processor, meaning that changes made in the dashboard may take longer to reflect in the API.
Posted Jul 23, 2025 - 21:01 UTC
This incident affected: Edge API, Core API, and Admin Dashboard.