Increased API latency

Incident Report for Flagsmith

Resolved

This incident has been resolved.
Posted 5 months ago. Nov 05, 2024 - 13:28 UTC

Update

Environment creation is functional again now.
Posted 5 months ago. Nov 05, 2024 - 10:37 UTC

Monitoring

API latency is back to normal. We are continuing to monitor.
Posted 5 months ago. Nov 05, 2024 - 10:32 UTC

Identified

The cause is due to a migration applied to the production database taking more resources than we anticipated. The migration has been completed and the load is normalising. We are monitoring and managing the load.

Currently, while this issue is ongoing, it is not possible to create new environments.
Posted 5 months ago. Nov 05, 2024 - 10:25 UTC

Investigating

We are currently investigating this issue.
Posted 5 months ago. Nov 05, 2024 - 10:19 UTC
This incident affected: Core API and Admin Dashboard.