Increased latency on subset of requests
Incident Report for Flagsmith
Resolved
This incident has been resolved.
Posted Sep 10, 2021 - 13:18 UTC
Monitoring
We have identified the issue as a large number of transactional database wait locks.

We have increased the size of our API server cluster which has reduced these wait locks, as well as reducing overall API latency.

We are monitoring the situation.
Posted Sep 10, 2021 - 12:33 UTC
Investigating
Hi,

We are seeing increased latency to our SDK endpoints for a small percentage of requests. We are investigating and will provide a further update as soon as we have more information.

Apologies for the degradation in service.
Posted Sep 10, 2021 - 11:34 UTC
This incident affected: Core API.